fix spurious executable perms in debuginfo

This commit is contained in:
Dan Callaghan 2014-07-13 20:22:23 +10:00
parent 680634475f
commit 6008ba6be3
3 changed files with 6 additions and 3 deletions

View File

@ -9,7 +9,7 @@ diff -ur lualdap-1.1.0.orig/Makefile lualdap-1.1.0/Makefile
- cp src/$(LIBNAME) $(LUA_LIBDIR)
- cd $(LUA_LIBDIR); ln -f -s $(LIBNAME) $T.so
+ mkdir -p $(DESTDIR)$(LUA_LIBDIR)
+ cp -p src/$(LIBNAME) $(DESTDIR)$(LUA_LIBDIR)
+ install -p -m0755 src/$(LIBNAME) $(DESTDIR)$(LUA_LIBDIR)
+ ln -s $(LIBNAME) $(DESTDIR)$(LUA_LIBDIR)/$T.so
clean:

View File

@ -9,7 +9,7 @@ Subject: [PATCH] Fix potential Lua error (attempt to concatenate a nil value)
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git a/src/lualdap.c b/src/lualdap.c
index 99c756e..d170038 100755
index 99c756e..d170038 100644
--- a/src/lualdap.c
+++ b/src/lualdap.c
@@ -436,10 +436,14 @@ static int result_message (lua_State *L) {

View File

@ -13,7 +13,7 @@
Name: lua-ldap
Version: 1.1.0
Release: 2%{?dist}
Release: 3%{?dist}
Summary: LDAP client library for Lua, using OpenLDAP
License: MIT
URL: http://www.keplerproject.org/lualdap/
@ -115,6 +115,9 @@ popd
%endif
%changelog
* Sun Jul 13 2014 Dan Callaghan <dcallagh@redhat.com> - 1.1.0-3
- fix perms on lualdap.c and lualdap.so
* Mon Jun 30 2014 Dan Callaghan <dcallagh@redhat.com> - 1.1.0-2
- cp -p, run tests in %%check